読者です 読者をやめる 読者になる 読者になる

pry-debugger と pry-nav の相性が悪い

Ruby

pry-debugger と pry-nav の両方をインストールしていると

pry:23: stack level too deep (SystemStackError)

と出て pry コマンドが起動しなくなってしまった.
調べてみると pry-debugger と pry-nav の相性が悪いようで,pry-nav をアンインストールしたら直った.

参考
https://github.com/pry/pry/issues/694

環境